Bug reports for Radex


#1

If you experience any issues or bugs please tell us about them here and tag @Neuron or @Cassini.

Every bug that you report and we fix makes Radex better!

Please submit in the following format:

  • Short bug description
  • How to reproduce
  • Link to broken eth transactions on Etherscan or a screenshot for a visual glitch

How to use Radex? Step by step tutorial
#2

Bug1
If I try to sell STN by clicking Sell button on Buy Orders table, I see wrong labels as I think.

  • Amount (how STN I want to sell, not eth)
  • Total (how much ETH I will received, not STN)
  • Fee, also maybe in STN, because I sell STN.

Bug2
Amount = 0.1 STN
Price 1 STN = 12 ETH
0.1*12 = 1.2 ETH
So, saller must received 1.2 eth
But it’s my tx. And I was receive only 0.097 eth (0.1 eth-fee, as I understand)


#3

Bug3
By this tx I was sell STN (or buy 0.1 eth) with price 0.08eth=1stn
So I sold 1.25 STN, not 0.1
And in Total line must be (Amount/Price) 0.1/0.08=1.25
But now there wrong formula (Amount*Price). This formula will be right if in Amount we will put STN. But now there ETH


#4

Fixed

Fixed


New release has been deployed yesterday, thank you for your feedback @investblog


#5

Thank you for fixing! After testing I say YES it’s all good now :blush:


#6

Found a little buggy thingie.

Was trying out/getting to get acquainted with your trading platform. When I tried to trade with the ZRX/ETH pair, I found out one needs to pay a small fee, for the ERC20 to ERC223 conversion (no probs with that). But I found out, I was out of ETH on my MetaMask account, so I tried to close the trade, by clicking on the ‘X’ mark on top, Without success - no response.

Is that a bug or a feature? xD


#7

It’s a feature, but we could have explained it better.

What happens when you click on upgrade is you call zrx.approve(zrx223.address, zrx.totalSupply()). This lets our ERC223 upgraded zrx manage your funds in the ERC20 ZRX token. As per usual, every ethereum transaction requires a small fee to be processed.

The X button closes this popup window (or a modal in bootstrap-speak) and will take you to the trading screen. But you won’t be able to trade without upgrading your ZRX, hence we don’t let you close it.

Currently Radex doesn’t have a read-only mode. You can only get through to the order book if you made sure to complete all the prerequisites for trading.

We have some plans to enable read-only view in the future. In the meantime I suppose we need to either hide the X button or make it more obvious that it’s disabled.


#8

That’s the thing, the ‘X’ does not close the pop-up window. Or is it just me?

Edit: scratch that, misread it (the disabling part)

Edit#2: maybe call another popup upon the onClick on the ‘X’ button, that offers the user a redirection to the main menu of your exchange, and in it, an explanation why.


#9

Max amount of token transfer is only 999.


#10

Fixed & deployed today


#11

@Neuron
On MacOSX High Sierra 10.13.3 / Safari 11.0.3 (13604.5.6)
If I go here:
~>Library>safari>databases>__IndexedDB>https_radex.ai_0>RdxAlphaStore011918>IndexedDB.sqlite3-wal
the file is 844MB.


Given that I don’t have an account this seems high :slight_smile:

For what it’s worth, I can’t reproduce this, and I notice the it being deleted every time I choose a different token on the website.


#12

It’s not a bug, it’s a feature :slight_smile: Let me explain why we are doing things this way.

First of all, as it is a decentralized exchange, there is no account. You simply interact with a smart contract using an Ethereum wallet that securely stores your ECDSA keypair.

If you read this blog post that announces Radex and describes its architecture you will see that we are using a well established pattern in computer science called event sourcing, and we use the blockchain as an append only log. While this data structure is very convenient at scale, for fast little lookups it is too slow, and a relational database would be much much faster. So what you do is at every block, you check if there is new info relevant to Radex, and if there is you append it to the relational database (sqlite in this case).

We are working on a version of the exchange where we are the ones hosting all this data in a relational database of our choice on our servers, and the website frontend can then communicate with our database using Radex API. However, this implicitly requires traders to trust us to maintain these servers and show accurate information, as that helps them make trading decisions. As such, we naïvely thought that traders would prefer to maintain a copy of this database on their computers that they have downloaded from the blockchain themselves (i.e. via metamask) and are thus more confident in data quality. But looks like there are some usability problems that come with this approach and we are working on resolving them in a way that improves performance and preserves privacy.

You can read more about Radex architecture and how it compares to other exchanges here. And the technology used to store all this data on your laptop is IndexedDB.


#13

Thx. I thought it was something like that, and I did have the window open in the background for days.